Cannot open Setup.log file installing Terminal Server Service Pack 4 (240072)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4

This article was previously published under Q240072

SYMPTOMS

When you attempt to install Service Pack 4 (SP4) for Windows NT Server 4.0, Terminal Server Edition, you may receive the following error message:
Service Pack Setup Error:
Service Pack Setup cannot open or modify your SETUP.LOG file.

CAUSE

This error message can occur if Update.exe in SP4 Setup cannot gain access to the %SystemRoot%\Repair\Setup.log file. The default location for this file is the C:\WTSRV\Repair folder.

RESOLUTION

To resolve this issue:
  1. Verify the existence of the Setup.log file in the %SystemRoot%\Repair folder. If this file does not exist, you must perform an Upgrade installation of Windows NT Server 4.0, Terminal Server Edition, to re-create the Setup.log file.
  2. Verify that the account that you are using to install SP4 has access to the Setup.log file. To do this, try to open the file with Notepad.exe. If you are unable to open the Setup.log file, use Windows NT Explorer to change the file-level permissions on the file. Grant the user account you are using appropriate permissions to open and modify the file.
  3. Verify that the following lines are present in the Setup.log file:

    [Files.WinNt]
    \%SystemRoot%\system32\hal.dll = "halapic.dll","%11xxx%"

    For example: \WTSRV\system32\hal.dll = "halapic.dll","14fbb")

    If these lines are not present or the path is incorrect, add the appropriate lines and make any necessary changes to the path to the Hal.dll file.

    Note that %SystemRoot% and %11xxx% are variables, and the values vary from one computer to another.

MORE INFORMATION

For additional informationrelated topics, click the article numbers below to view the articles in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


Modification Type:MinorLast Reviewed:7/1/2004
Keywords:kberrmsg kbprb kbsetup KB240072