Client Programs May Not Be Installed During SBS 4.5 Setup or Upgrade (240068)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.5
This article was previously published under Q240068 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you install Small Business Server (SBS) 4.5 or upgrade to SBS 4.5 from SBS 4.0, you may receive one or more of the following error messages when you install the client programs:
- MDACSET - illegal operation
- mdacset caused an invalid pagefault in module mdacset.exe at 015f:00403072
If you receive an error message and click OK, one of the following things occurs:
CAUSE
This behavior can occur if the Microsoft Installer files are corrupted or are missing certain components.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue:
- Verify that the System account has Full Control permissions on the following folders:
- C:
- Winnt.sbs
- ClientApps
- The root of the drive where the ClientApps folder is installed (if it is not drive C).
NOTE: The System account is not part of the Everyone group. If Full Control permissions are specified for the Everyone group but the System account is not specifically mentioned, you should add the System account to the permissions list.
- Start Registry Editor (Regedt32.exe) and locate the following registry key:
HKEY_LOCAL_MACHINE\System\Current Control Set\Services\MSIServer
- Locate the Image Path value in this key. The correct value is:
C:\Winnt.sbs\System32\Msiexec.exe /v
- Make sure the following two files exist in this folder:
If the Microsoft Installer files are corrupted, use the following steps:
- Start the client in MS-DOS mode.
- Rename the Msi.dll, Msihnd.dll, and Msiexec.exe files.
- Restart the client in Normal mode.
- Run Instmsi.exe from the Msi folder on the Outlook 2000 CD-ROM.
- Run Outlook 2000 Setup directly from the CD-ROM.
REFERENCES
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
290301
Description of the Windows Installer CleanUp Utility
Modification Type: | Major | Last Reviewed: | 5/5/2004 |
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Keywords: | kbenv kbprb KB240068 |
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