Works: Error Message When You Remove Word in Works Suite Add-in (239993)



The information in this article applies to:

  • Microsoft Works Suite 2000
  • Microsoft Works Suite 2001

This article was previously published under Q239993

SYMPTOMS

When you remove the Word in Works Suite Add-in, you may receive an error message similar to the following when you restart the computer:
Works can not access one or more required files. The files may have been renamed, deleted, or moved. Try reinstalling Works and then start the program again.
If you then attempt to start Microsoft Works Suite, you receive the following error message:
The Wksgen.dll file cannot start. Check the file to determine the problem.

CAUSE

This behavior can occur because removing the Word in Works Suite Add-in removes the Resource Language Keys in the Windows registry which causes the program to be unable to find the Works language .dll files.

RESOLUTION

To resolve this issue:

  1. Insert Works Suite Disk 2 into your CD-ROM drive.
  2. Double-click the My Computer icon on the desktop.
  3. Right-click the CD-ROM drive icon, and then click Explore.
  4. Double-click the Msworks folder.
  5. Double-click the Wks2000.msi file.
  6. Click Remove, and then follow the instructions on the screen to remove Works.
  7. When you are prompted to restart the computer, click Yes.
  8. Double-click the Wks2000.msi file, and then follow the instructions on the screen to reinstall Works.
  9. When you are prompted to restart the computer, click Yes.
  10. Insert Works Suite Disk 1 into your CD-ROM drive.
  11. Right-click the CD-ROM drive icon, and then click Explore.
  12. Double-click the Wordadd folder.
  13. Double-click the Setup.exe file.
  14. Follow the instructions on the screen to install the Word in Works Suite Add-in.

Modification Type:MajorLast Reviewed:6/28/2004
Keywords:kbAddIn kbenv kberrmsg kbprb kbsetup KB239993