Error Message: Winsock Services Could Not Start Due to a Critical Error (239841)



The information in this article applies to:

  • Microsoft ActiveSync 3.0
  • Microsoft ActiveSync 3.1

This article was previously published under Q239841

SYMPTOMS

If ActiveSync is installed on a desktop computer that is running Microsoft Windows 95 configured to accept calls by using Dial-Up Networking Server (from Microsoft Plus! for Windows 95 or from Dial-Up Networking 1.2), you may receive the following error message when you attempt to run ActiveSync remotely over the dial-up connection:
Communications Error
Cannot start communication with the desktop computer. Winsock services could not start due to a critical error "Error 10065." Please reconnect your device.
Reconnecting the device does not resolve the problem.

The error message may also occur if another client attempts to connect to the Windows 95-based computer by using Dial-Up Networking.

CAUSE

The Remote Networking connection on the Windows CE-based device needs to be reconfigured to use a server-assigned IP address.

RESOLUTION

To resolve this issue, configure the Remote Networking connection on the Windows CE-based device to use a static IP address of 192.168.55.100 and then reconfigure it to use a server-assigned IP address:
  1. In the Windows CE-based device's Remote Networking folder, tap the connection for the desktop computer you are trying to connect to.
  2. Tap TCP/IP Settings.
  3. Tap to clear the Server-Assigned IP Address check box.
  4. Type 192.168.55.100 as the IP address.
  5. Tap to select the Server-Assigned IP Address check box.
  6. Tap OK.

Modification Type:MinorLast Reviewed:2/4/2004
Keywords:kbDialUp kbenv kberrmsg kbprb KB239841