SBS Internet Reports Wizard Hangs with ODBC Error Message (239733)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q239733

SYMPTOMS

When you run the Internet Reporting Wizard included with Small Business Server (SBS) 4.5, you may receive the following error message:
-2147467259 [Microsoft][ODBC Text Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already open exclusively by another user, or you need permission to view its data.

CAUSE

This issue can occur because the reporting wizard combines all the Web Proxy log files into a single comma separated file named Proxy.csv in the \SmallBusiness\Html\Logs folder.

RESOLUTION

To work around this issue, remove some of the older Proxy log files.

NOTE: By default the Proxy Server on SBS is configured to not overwrite any log files.

MORE INFORMATION

When the Proxy.csv file is created, an Active Server Page can query the .csv file to generate the Proxy report Web pages. The error message may appear if the Active Server Page attempts to query the .csv file before the log files are combined. This can occur when there are many Web Proxy log files or the Proxy log files are very large. The exact number and size of the log files that will cause the error condition will vary depending on the performance of the SBS server.

The log files are stored by default in the \Winnt.sbs\System32\Msplogs folder. The files are named W3yymmdd.log (YYMMDD is the Year, Month, and Day the file was created). Proxy Server can be configured to overwrite the older log files by changing the logging option on the Web Proxy properties. Click the box for logging option to Limit number of old log files to and set the day to a short time period. Stop and restart the Proxy Services. Proxy automatically removes the log files that are older than the specified number of days. If the Internet Report still does not work, then lower the number of days until the report functions.

Microsoft has confirmed that this is a problem in Microsoft BackOffice Small Business Server version 4.5.
For additional information about , please click the article number(s) below to view the article(s) in the Microsoft Knowledge Base:

236179 Server Status Tool Reports Web Proxy and Winsock Proxy Errors


Modification Type:MajorLast Reviewed:8/25/1999
Keywords:kbenv kberrmsg kbprb KB239733