ACPI-Enabled Laptop Prompts Twice for a Hardware Profile (239697)
The information in this article applies to:
- Microsoft Windows 98
- Microsoft Windows 98 Second Edition
This article was previously published under Q239697 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you start a laptop computer that uses Advanced Configuration and Power Interface (ACPI) power management, you may be prompted for a hardware profile twice. If you create more than one hardware profile, and then restart your computer, you may receive a message similar to:
Windows cannot determine what configuration your computer is in.
Select one of the following:
Undocked
Undocked2
None of the above
You may then receive the following error message on a blue screen titled "Dock Change":
Windows is unable to determine your hardware profile. Is "Undocked"
the current profile
Press Y for Yes or N for No
CAUSE
This problem occurs because the computer's BIOS supports both ACPI and Plug and Play. The real-mode boot sequence detects the Plug and Play BIOS and prompts for the profile, and then the protected-mode boot sequence detects ACPI support and displays a blue screen requesting the profile again.
RESOLUTIONA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem. To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English-language version of this fix should have the following file attributes or later:
Windows 98:
Date Time Version Size File name
---------------------------------------------------
08/18/99 12:30p 4.10.2103 222,670 Winboot.sys
12/13/99 11:01p 115,689 Configmg.vxd
Windows 98 Second Edition:
Date Time Version Size File name
---------------------------------------------------
09/13/99 05:45p 4.10.2223 222,670 Winboot.sys
08/18/99 11:51a 125,081 Configmg.vxd
WORKAROUND
To work around this issue, read each prompt carefully and select the same hardware profile during the second prompt as the first prompt.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
The package for this hotfix has been re-released due to version
problems of the original binaries wherein they were too low and
would not be installed properly.
Modification Type: | Minor | Last Reviewed: | 10/18/2005 |
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Keywords: | kbHotfixServer kbQFE kbHardware kbprb KB239697 |
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