Current Sessions Dialog Box in Proxy Server May Be Inaccurate (239581)



The information in this article applies to:

  • Microsoft Proxy Server 2.0

This article was previously published under Q239581

SYMPTOMS

When you view the Current Sessions dialog box for the Web Proxy service, sessions for users may still be present in the list for more than 15 minutes after a user has stopped using the proxy server or disconnected from the network.

CAUSE

This is normal behavior. The sessions time out after about 15 minutes of inactivity. Because of the connectionless nature of the HTTP protocol, the proxy server estimates how many sessions still exist.

For example, a user browsing the Web may be idle for several minutes. If the proxy server does not receive any further requests from the user after 15 minutes, the user is removed from the list. Otherwise, users remain in the list even if they have closed their Web browser or shut down their client computer.

MORE INFORMATION

If you need more accurate information about the load on your server, use one or more of the following Performance Monitor counters:
  • Object: Web Proxy Server Service
    Instance: N/A
    Counter: Current Average Milliseconds/Request
  • Object: Web Proxy Server Service
    Instance: N/A
    Counter: Requests/Sec

Modification Type:MajorLast Reviewed:12/6/2000
Keywords:kbprb KB239581