Exchange Clients Appear to Intermittently Hang During Normal Operation (239132)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q239132

SYMPTOMS

Microsoft Exchange and Outlook Clients appear to stop responding (hang) periodically during normal operation when used in conjunction with an Exchange Server computer that has clients that connect over slower connections.

CAUSE

The remote procedure call (RPC) Receive Any Thread in use by the Microsoft Exchange Information Store Service is waiting to receive additional information from a client.

RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition.

This problem was first corrected in Windows NT Server 4.0 Service Pack 6 and Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

MORE INFORMATION

Clients that are connecting to the Exchange Server computer over slower connections have a higher latency in the sending and receiving of data grams. The RPC Receive Any Thread is waiting on additional data grams before processing the clients request. This causes other clients that are attempting to communicate on the Receive Any thread to the Exchange Information Store to appear to hang while waiting for a response from the Exchange Server computer.

For additional information on performance issues, please refer to the following article in the Microsoft Knowledge Base:

232512 TCP/IP may Retransmit Packets Prematurely


Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB239132