The Newprof.exe Program Deletes Your Profile When You Run it Twice (239093)



The information in this article applies to:

  • Microsoft Outlook 2000
  • Microsoft Outlook 98
  • Microsoft Outlook 97

This article was previously published under Q239093

SYMPTOMS

When you run the Newprof.exe program for the second time by using the .prf file with the OverwriteProfile setting to Yes, the profile is overwritten, but the profile that is created does not contain any settings that are specified in the .prf file.

CAUSE

When you use the -S option with the Newprof.exe program, you receive a dialog box that prompts you to choose a .prf file and displays the status and the error message. When you use the -Z option with the Newprof.exe program, you receive a dialog box that displays the Messaging Application Programming Interface (MAPI) error codes if any errors were encountered. This option requires the -S option to work correctly.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Exchange Server version 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:

File nameVersion
Newprof.exe5.5.3117.0

WORKAROUND

To work around this problem, manually delete the profile through Control Panel or in the registry before you try to run the Newprof.exe program for the second time.

To delete your profile through Control Panel:
  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, click Mail, and then click Show Profiles.
  3. Click the profile that you want to delete, and then click Remove.
To delete your profile in the registry:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles

  3. Open the registry key, locate your profile, right-click your profile, and then click Delete.

STATUS

Microsoft has confirmed that this is a problem in Newprof.exe version 5.5.

MORE INFORMATION


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB239093