XFOR: Users Cannot Reply to SMTP Messages in a PST After Migration (237993)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3

This article was previously published under Q237993

SYMPTOMS

When you migrate users from Lotus Notes directly into personal folder files (PSTs), users are unable to reply to messages from SMTP addresses. The messages in the PST can be opened correctly, but the recipients on the message To line are not resolved and no address is associated with the display name. However, when you migrate users directly to an Exchange Server mailbox, the messages appear correctly to the user, and they can be replied to correctly.

CAUSE

The Migration wizard does not set the PR_SENDER_ENTRYID. This is by design, as the intent is to have the client resolve the address to the latest one in the global address list after the migration is finished. This issue only appears when you migrate users directly to PSTs. Migrating the message to the Exchange Server information store creates the PR_SENDER_ENTRYID of a one-off address type. The Emsmdb32.dll does this, as it is the responsibility of the transport to create this property before submitting the message. The Migration wizard now sets the PR_SENDER_ENTRYID for the sender when migrating messages directly to PSTs.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

Modification Type:MajorLast Reviewed:10/2/2003
Keywords:kbbug kbExchange550preSP4fix kbExchange550sp4Fix kbfix kbQFE KB237993