PRB: GetMailboxTable Method only Return Mailboxes with Resources (237969)
The information in this article applies to:
- Microsoft Exchange Development Kit (EDK) 5.0
- Microsoft Exchange Development Kit (EDK) 5.5
This article was previously published under Q237969 SYMPTOMS
IExchangeManageStore::GetMailboxTable will only return mailboxes that have resources.
CAUSE
The mailbox folder is created in the information store, the first time the mailbox account logs in. Prior to the mailbox account logging in, there are no resources for that specific account.
RESOLUTION
A workaround would be to programmatically log into all mailboxes before calling IExchangeManageStore::GetMailboxTable.
For more information, please see the following article in the Knowledge Base:
194627 HOWTO: Opening Mailboxes with Privileged Access
Another alternative would be to use ADSI and LDAP. Please see:
223151 HOWTO: Search and List Recipients Using IDirectorySearch
STATUS
This is by design.
MORE INFORMATION
If the mailbox has never been logged into, then it will not have any resources. To see which mailboxes have resources, run the Microsoft Exchange Admin program (Admin.exe). The mailboxes with resources are listed under Configuration \Servers \Server-Name\ Private Information Store \ Mailbox Resources.
Modification Type: | Minor | Last Reviewed: | 3/4/2004 |
---|
Keywords: | kbMsg kbprb KB237969 |
---|
|