SYMPTOMS
WARNING:This information is preliminary and has not been confirmed or
tested by Microsoft. Use only with discretion. When you run Setup
for Microsoft Office 2000, you may receive the following error message:
Installing this product requires the Windows Installer.
An error occurred when installing or upgrading the Windows Installer.
Also, when you run Instmsi.exe to install the Windows Installer, you
receive the following error message:
Error 1324. The
folder path 'name of a folder' contains an invalid
character.
CAUSE
These error messages may appear if all of the following are
true:
- You are using Microsoft Windows 95 or Microsoft Windows 98.
- You have turned on User Profiles.
- Your profile contains a slash (/) character in the name
(for example, Jones/Smith).
NOTE: You should not be able to create a user name with a forward
slash (/), because Windows cannot create a folder in the Windows\Profiles
folder (the forward slash is not a valid character for a folder name).
Therefore, this may be an indication that the profile is damaged.
WORKAROUND
Follow these steps to work around the problem:
Method 1: Run Setup under a different profile.
If the profile under which you are logged on is corrupted, you
may be able to run Setup under a different user profile. If you log on under a
different profile and you can install Office, you may need to delete and
recreate the problematic profile. Otherwise, you may encounter the same problem
when you try to install Office when logged back on under that profile.
For more information about removing an existing user profile, please
see the following article in the Microsoft Knowledge Base:
156826 How to disable and delete user profiles
NOTE: If you have User Profiles turned on and a per-user Start menu,
each user who has an existing profile on Windows 95 or Windows 98 must run
Setup for Office. The only users who do not have to run Setup are those who do
not have an existing profile on the computer; when they log on for the first
time, the default User Profile is copied into their profile. This default User
Profile includes all of the registry information and shortcuts necessary to
start Office programs.
For more information about installing Office
2000 with User Profiles turned on, please see the following article in the
Microsoft Knowledge Base:
302846 An "Application must be installed" error message occurs when you start an Office programs
If this
method does not resolve the problem, try Method 2.
Method 2: Turn off user profiles before running Setup.
- On the Start menu, point to Settings, and click Control Panel. Double-click the Passwords icon.
- Click the User Profiles tab. Click All users of this computer use the same preferences and desktop settings.
- Click OK. Restart the computer if prompted to do so.
- Install Office 2000.
If the installation of Office is successful, you can turn on
User Profiles again.
NOTE: If you turn on User Profiles again, you may encounter problems
running the Office programs. For information about the additional steps that
you must follow before you run Office 2000 programs after you turn on User
Profiles, please see the following articles in the Microsoft Knowledge Base:
234017 Office program shortcuts are missing
302846 An "Application must be installed" error message occurs when you start an Office programs