Outlook 2000 stops responding when using the Quick Find feature (237912)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q237912
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When using Quick Find on the toolbar or Find a Contact on the Advanced toolbar to find a contact, Outlook may stop responding, or you may receive one of the following error messages:
An application error has occurred. Access violation 0xc0000005

- or -

OUTLOOK caused an invalid page fault in module MSO9.DLL at 015f:308c9dab

-or-

OUTLOOK.exe has generated errors and will be closed by Windows. You will need to restart the program. An error log is being created.
NOTE: The hex address might be different in the error message received by the user.

CAUSE

You may have a damaged QuickFindMRU registry key.

RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:

245025 How to obtain and install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)

To temporarily work around this problem, remove the QuickFindMRU registry key, and then restart Outlook.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

The information in this key is written as hexadecimal values and is not editable. To fix the problem, follow these steps:
  1. Close all open programs.
  2. On the Start menu, click Run, and type regedit in the Open box.
  3. Navigate to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Contact\QuickFindMRU

  4. Click to select the key, and on the Edit menu, click Delete. When you receive the Confirm Key Delete prompt, click Yes.
  5. Quit the Registry Editor, and start Outlook.
When you restart Outlook, the key is recreated. Your previous Quick Find list is removed and will be rebuilt.

REFERENCES

For additional information about other causes of invalid page faults occurring in module Mso9.dll, click the following article numbers to view the articles in the Microsoft Knowledge Base:

223607 Fatal error linking file to contact from Word

240813 Errors when sending e-mail from an Office Program

241817 Invalid page fault in module Mso9.dll


Modification Type:MinorLast Reviewed:8/11/2004
Keywords:kbRegistry kbbug kbfix KB237912