XADM: Exchange Server Corrupts Japanese cc:Mail Message Subject Routing It to the Internet (237838)



The information in this article applies to:

  • Microsoft Exchange Server 5.5 SP2, when used with:
    • the operating system: Microsoft Windows NT
  • Microsoft Exchange Server 5.5, when used with:
    • the operating system: Microsoft Windows NT
  • Microsoft Exchange Server 5.5 SP1, when used with:
    • the operating system: Microsoft Windows NT

This article was previously published under Q237838

SYMPTOMS

When you set up an Exchange Server computer to be the SMTP gateway of a Japanese Lotus cc:Mail post office, if a cc:Mail user sends a Japanese message to an Internet address, all Japanese characters become question marks (?) at the receiver side.

CAUSE

When the message is exported from Lotus cc:Mail to Exchange Server, all content is converted to UNICODE. But the native code page information (CPID) is not saved, so the default Windows NT CPID is used instead.

When the message is converted from UNICODE to the native code page by Internet Mail (IMAIL), all the message properties are converted to the default CPID.

If the computer running Windows NT Server is running the English version, all Japanese characters are converted to question marks.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbExchange550preSP4fix kbExchange550sp4Fix kbfix kbQFE KB237838