SBS: "Access Violation" Error Message in Rezwizu.exe or Addusrw.exe (237670)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q237670

SYMPTOMS

When you attempt to create a new user by using the User Account Wizard or to modify a user's permissions to resources by using the User Access Wizard, you may receive one of the following Dr. Watson error messages:
REZWIZU.EXE - Exception: Access Violation (0xc0000005)

-or-

ADDUSRW.EXE - Exception: Access Violation (0xc0000005)

CAUSE

These wizards (Addusrw.exe and Rezwizu.exe) are not compatible with some versions of the Mfc42.dll and Mfc42u.dll files.

RESOLUTION

To resolve this issue, restore the correct version of these files from the Option Pack and place them in the Smallbusiness folder. You do not need to reregister these dynamic-link libraries (DLLs). To do this, follow these steps:
  1. Insert SBS 4.5 CD-ROM 2 in the CD-ROM drive.
  2. At a command prompt, type:

    extract CD-ROM:\ntoptpak\en\x86\winnt.srv\msmqocm.cab mfc42*.dll


    Then press ENTER.

    Where CD-ROM is the driver letter of your CD-ROM drive.
NOTE: The extracted files inherit any permissions that apply to the target directory of the extract command, which, in the above example defaults to the home directory of the currently logged on user. The System account needs Full Control access to these two files. Replacing these files in the %SystemRoot%\System32 folder may cause problems with third-party programs that require the updated versions. Also, rename the old Mfc42*.dll files in the Winnt.sbs\System32 folder. If you do not, you may receive a sharing violation error message.

MORE INFORMATION

This error can also occur if the Description field for User Account Information in the User Account Wizard is left blank. If you suspect this is the cause, add a value to the description field.

Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbenv kberrmsg kbprb KB237670