SBS: "Upgrade Client Applications" Does Not Appear in "To Do" List (237552)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q237552
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The Small Business Server (SBS) 4.5 To Do list may not display the Upgrade Client Applications option.

CAUSE

The Upgrade Client Applications option should be displayed on SBS 4.5-based computers that are upgraded from SBS 4.0. However, the upgrade process may not create the necessary registry key for the Upgrade Client Applications option.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, manually add or modify the following registry keys:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\SMALLBUSINESS\CONSOLE\TODOLIST\MICROSOFT

  3. Double-click the LinkCount value. Increase the current LinkCount value by one. Click OK to save the value.
  4. On the Edit menu, click Add Key, and then add a key named Linkx, where x is the number of the LinkCount value in step 3.
  5. Click the Linkx key.
  6. On the Edit menu, click Add Value, and then add the following registry values:
    • Value Name: Action
      Data Type: REG_SZ
      Value: %SystemDrive%\smallbusiness\scw.exe (Note: replace %SystemDrive% with the drive on which SBS is installed
    • Value Name: Enabled
      Data Type: REG_DWORD
      Value: 1
    • Value Name: Target
      Data Type: REG_DWORD
      Value: 0
    • Value Name: TitleText
      Date Type: REG_SZ
      Value: Upgrade Client Applications
    • Value Name: URL
      Date Type: REG_SZ
      Value: <Blank>
    • Value Name: DescriptionText
      Date Type: REG_SZ
      Value: Click Upgrade Client Applications to upgrade the applications on client computers attached to your Small Business Server network. You need to perform this task once for each client computer attached to your network.
  7. Quit Registry Editor.

Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbenv kbprb KB237552