BUG: Rchelp.Sys Can Cause CHKDSK to Run Continuously (235771)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q235771 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
After installing Systems Management Server version 2.0 you may notice clients running CHKDSK every time your computer is started. This behavior goes away as soon as the the Systems Management Server client is removed from the computer.
You may also see the following error message.
"Cannot open volume for direct access"
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To work around the problem, edit the following registry key: - Start Registry Editor (Regedt32.exe).
- Locate the Start value under the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\rchelp
- Select the DWORD Value "Start"
- On the Edit menu, click DWORD, type 2, and then click OK.
- Quit Registry Editor.
NOTE: Another workaround is to convert the BOOT partition to NTFS.
This has the effect of changing the startup value from "System" to
"Automatic", starting it later in the boot process, which solves the CHKDSK
problem.
CHKDSK will still work normally when you start the computer and the Systems
Management Server Remote Control functionality is retained.
CAUSE
This is caused by the startup configuration of the Rchelp.sys driver.
This file is trying to load at boot time and does not allow chkdsk to have exclusive access to the volume.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbBug kbClient kbConfig kbfix kbRemoteProg kbsetup KB235771 |
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