XIMS: Setting a Low Output Saturation Buffer May Result in Client Disconnects After LISTX Command Is Sent (235486)



The information in this article applies to:

  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3

This article was previously published under Q235486

SYMPTOMS

If you send a listx command to the Microsoft Exchange Chat Service, the server may unexpectedly end the connection to the client. When this occurs, a list of chat rooms and their topics may be displayed, but the list may be outdated.

CAUSE

This problem can occur if the output saturation limit is set between 1 and 60 kilobytes (KB).

RESOLUTION

To resolve this problem, set the output saturation limit to a value greater than 128 KB:
  1. Open Microsoft Management Console, and then open the Microsoft Chat snap-in.
  2. Under the chat server name, click User Classes.
  3. Under Defined User Classes, click the Settings tab, and then set Output Saturation Limit to a value greater than 128 KB. The default setting is 64 KB.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The output saturation limit designates the maximum amount of data that the Exchange Chat Service can buffer for a client before it drops the client connection. You can set a value from 1 to 1024 kilobytes (KB).

For additional information about a related issue, click the article number below to view the article in the Microsoft Knowledge Base:

228860 XIMS: Chat Service Ends Connection after LISTX Command is Sent


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB235486