SMS: The Software Metering Client Agent Is Unable to Activate the Retry Mode (235153)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q235153

SYMPTOMS

When a Software Metering Client Agent is unable to contact a software metering server, the Software Metering Client Agent goes into the Retry mode. However, the attempted retry may not occur.

CAUSE

This behavior may occur because the default configuration settings prevent the retry from occurring. By default, the settings in the Configuration Polling Interval box and the Delay Before Retrying box are both set to 240 minutes. These settings disable the attempted connection retry as the polling interval is activated before the retry can occur.

WORKAROUND

To work around this behavior, the setting in the Delay Before Retrying box must be set to a value which is less than the setting in the Configuration Polling Interval box.

NOTE: It is recommended that you configure the preceding settings before you install any clients.

If these settings had not been configured before you enabled the Software Metering Client Agent, the new configuration settings cannot be updated until the next successful connection of the Software Metering Client Agent to the software metering server.

An example of a configuration:

Retries = 5
Delay Before Retrying = 60
Configuration Polling Interval = 240

With the preceding configuration, the Software Metering Client Agent can make five attempts to connect to the software metering server every 60 minutes. The setting in the Configuration Polling Interval box ensures that a polling interval occurs every 240 minutes.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbBug kbClient kbConfig kbprb kbServer kbsetup kbsmsAdmin kbsmsMeter KB235153