Dr. Watson Does Not Run with Certain Extensible Counters (234860)
This article was previously published under Q234860
SYMPTOMS
Dr. Watson is invoked whenever a user-mode exception occurs. Sometimes, Dr. Watson stops responding (hangs) and neither the OK or Cancel buttons are enabled. You may also see an event ID 1000 from perflib in the Application Event log, stating that Dr. Watson could not gain access to performance data.
CAUSE
There is an extensible counter that is keeping Dr. Watson from being able to query performance data.
RESOLUTION
Perform the troubleshooting steps in the following Microsoft Knowledge Base article:
152513 Troubleshooting Performance Monitor Counter Problems
Using this article, identify which extensible counter is causing the problem and either replace the .dll file associated with the counter with an updated file or disable the counter.
MORE INFORMATION
Misbehaving extensible counters can cause Performance Monitor or other third-party programs that query performance data to not work as well.
Modification Type: |
Major |
Last Reviewed: |
7/30/2001 |
Keywords: |
kb3rdparty kbprb KB234860 |
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