Windows 95/98 Clients Hang with "Mprexe.exe Not Responding" Error Message (234647)
The information in this article applies to:
- Microsoft Windows 98
- Microsoft Windows 95
- Microsoft Windows NT Server 4.0
- Microsoft SQL Server 7.0
This article was previously published under Q234647 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
Windows 95 clients using Microsoft distributed file system (Dfs) or Windows 98 clients may stop responding (hang) in any of the following situations:
- Windows 95 Dfs clients or Windows 98 clients hang while logging on to a Windows NT 4.0 domain controller that has a Dfs root share and SQL 7.0 installed.
- After successfully logging on to a domain, Windows 95 Dfs clients and Windows 98 clients hang when trying to connect to or browse a Windows NT 4.0 domain controller (or member server) that has a Dfs root share and SQL 7.0 installed.
- Windows 95 Dfs clients or Windows 98 clients hang while logging on to a Windows NT 4.0 domain controller, if the user has a logon script that maps a drive to a Windows NT 4.0 domain controller (or member server) that has a Dfs root share and SQL 7.0 installed.
When a user is trying to log on, Windows 98-based computers may display Creating User Profiles and Loading System Policies dialog boxes, and then hang. If you press CTRL+ALT+DELETE, you see that Mprexe.exe is not responding. NOTE: This problem has also been observed in environments without SQL or Dfs; the problem was resolved using the solution listed above. Mprexe.exe may not be responding for many underlying reasons. This article addresses one possible solution.
CAUSE
SQL 7.0 installs the following key on the SQL server, which Windows 98 clients and Windows 95 Dfs clients cannot process correctly:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters\MaxMpxCt
This key has a REG_DWORD value of x1FF.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. - Start Registry Editor (Regedt32.exe) on the Windows NT 4.0 server that has the Dfs root share and SQL 7.0 installed.
- Locate the REG_DWORD x1FF value under the following key in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters\MaxMpxCt
- On the Edit menu, click DWORD, type 1FE, click Hex, and then click OK.
- Quit Registry Editor.
- Reboot the computer.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 12/20/2004 |
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Keywords: | kbenv kbprb KB234647 |
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