CMAK Profile Is Not Default Dialer if DUN Is Already Installed (234564)



The information in this article applies to:

  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer Administration Kit 5.0
  • Microsoft Internet Explorer Administration Kit 5.01

This article was previously published under Q234564

SYMPTOMS

After you install a Microsoft Connection Manager Administration Kit (CMAK) profile on a client computer with Dial-Up Networking (DUN) installed, the profile may not be set as the default dialer. Because of this, you may be unable to obtain access to the CMAK profile address books, and so on. This behavior may occur when you are installing sign-up Internet Explorer packages with the Internet Explorer Administration Kit (IEAK).

CAUSE

This problem can occur because of an error in the way that the Internet Connection Wizard (ICW) parses the CMAK profile. ICW actually creates two DUN entries for the CMAK profile; the default dialer is not set to the CMAK profile (it is still set for DUN). Because of this, DUN starts instead of the CMAK profile.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 5.01 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

This fix should be installed as a custom component by using the IEAK to build a custom Internet Explorer installer package. The hotfix installer package is named Q234564.exe.

The English version of this fix should have the following file attributes or later:
   Date        Time   Version       Size    File name     Platform
   ---------------------------------------------------------------
   02/02/2000  06:07p 5.0.3014.200  72,464  Isign32.dll   x86
   02/02/2000  06:07p 5.0.3014.200  151,312 Icwhelp.dll   x86
				

WORKAROUND

Workaround for Internet Explorer 5

NOTE: This workaround only works when the client performs a server-based signup. A registry change is made after the CMAK profile is downloaded and installed on your computer. The registry change sets CMAK as the default dialer during the branding process on the server-based signup. This is done by editing the .ins file that is used for the branding process and adding a custom entry at the very end of the .ins file (it must be the last entry in the file). You must also create a custom .cab file that contains an .inf file that is extracted and read during the branding process. The .inf file has entries to make the appropriate registry change to set CMAK as the default dial-out utility to use when Internet Explorer is double-clicked (dial-out on demand). The .cab file must be downloadable and must have a valid Universal Resource Locator (URL) address. Typically, you can place it in the same location as the .ins file. Use the IEAK Iexpress tool to create the .cab file.

WARNING: This procedure has only been tested with earlier clients, not Microsoft Windows NT-based clients.

The following entries must be added to the .ins file and to the .inf file that goes into the custom .cab file:

The .ins File Entries

[ExtRegInf]
CMAK profile name=*,CMAK profile name.inf,DefaultInstall

[Custom Branding]
Branding=http://customer/signup/CMAK profile name.cab

The .inf File Entries for the .cab File

[Version]
Signature=$Chicago$
AdvancedINF=2.5

[DefaultInstall]
AddReg=top

[top]
HKCU,"RemoteAccess",InternetProfile,0,"CMAK Profile Name"

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbDialUp kbenv kbprb KB234564