Memory Leak When Performance Counters Are Not Available (234351)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Server 4.0 SP4
- Microsoft Windows NT Server 4.0 SP5
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
This article was previously published under Q234351
NEW SECTION page 374
SYMPTOMS
When you use a program that attempts to gain access to a performance counter
that has not been installed, your computer's performance may degrade or the
computer may stop responding (hang) because of a memory leak. For example,
if you use the Microsoft Systems Management Server (SMS) 2.0 Healthmon tool
on a computer that does not have the Microsoft Simple Network Management
Protocol (SNMP) configured, the computer may hang and you may be required to
restart your computer periodically.
This problem may also occur if any application, such as system management products, tries to access performance counters on the computer in question.
CAUSE
This problem occurs because memory is not being deallocated correctly when an attempt is made to write data to the corresponding performance counter that is not available. It may be necessary for you to determine which performance counters your program is attempting to update to ensure their availability.
RESOLUTIONWindows NT Server or Workstation 4.0
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or
the individual software update. For information on obtaining the
latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft
Product Support Services. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:
Windows NT Server 4.0, Terminal Server EditionTo resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
WORKAROUND
To work around this problem, install the SNMP service on your computer. To do this:
- Click Start, point to Settings, click Control Panel, and then double-click Network.
- On the Services tab, click Add, and then double-click SNMP Service.
- When you are prompted, type the full path to the installation files folder (for example, D:\I386), click Continue, and then click Close.
- Reinstall the latest Windows NT 4.0 service pack, and then restart the computer.
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbinterop kbnetwork kbQFE KB234351 |
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