Event Log Fills with Printer Creation/Deletion Notifications (234330)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q234330

SYMPTOMS

When you are running Windows 2000 Server with Terminal Services enabled, you may receive an error message that states that the System log is full. When you view the System log, it may be full of informational events from the Print source. The following informational events are examples of the events you may see:
SOURCE: Print
CATEGORY: None
EVENT ID: 9
DESCRIPTION: Printer HP LaserJet 4/4M Plus PS 600/LCDPP/Session 1 was set.
SOURCE: Print
CATEGORY: None
EVENT ID: 15
DESCRIPTION: Printer HP LaserJet 4/4M Plus PS 600/LCDPP/Session 1 was created.
SOURCE: Print
CATEGORY: None
EVENT ID: 20
DESCRIPTION: Printer Driver HP LaserJet 4/4M Plus PS 600 for Windows NT x86 Version-3 was added or updated. Files:- PSCRIPT5.DLL, PS5UI.DLL, HP4PLUS6.PPD, PSCRIPT.HLP, PSCRIPT.NTF.

CAUSE

These events are logged when a Terminal Services client with a local printer attached connects to a server. The server loads the drivers for the client's local printer to enable the client to print to its local printer from within the client session.

RESOLUTION

To resolve this issue, adjust the Event log settings or turn off these informational events.

To Adjust the Event log Settings

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Administrative Tools, and then double-click Event Viewer.
  3. Right-click the System Log file, and then click Properties.
  4. Click Overwrite as needed, or set a larger maximum log file size.
  5. Click OK.

To Turn Off Informational Events

  1. Go into your printer folder, and then click File.
  2. Click Server Properties.
  3. Click the Advanced tab.
  4. The spooler events can then be turned off.
Note that if you turn off Information Events, you no longer write to the System log when you print documents.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

227896 Error Message: The System Log Is Full

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:11/13/2003
Keywords:kberrmsg kbprb KB234330