Baseball 2000 Err Msg: Baseball 2000 Caused an Invalid Page Fault in Module Graphics.dll (234199)
The information in this article applies to:
This article was previously published under Q234199 SYMPTOMS
When you start Microsoft Baseball 2000, you may receive the following
error message:
This program has performed an illegal operation and will be shut down.
When you click Details, you receive the following error message:
Baseball 2000 caused an invalid page fault in module Graphics.dll.
CAUSE
This behavior can occur if any of the following conditions are true:
- One megabyte (MB) or less of video memory is installed on
your primary video adapter.
- Your video driver is outdated or does not support
DirectDraw.
- Your video adapter does not support DirectDraw.
- The Hardware Acceleration setting on your computer is not set
to Full.
- An incorrect or duplicate monitor is installed on your
computer.
RESOLUTION
To resolve this issue, use the following methods in the order in which
they are presented.
Upgrade Your Video Adapter
To run Baseball 2000, you must have a video adapter with at least
2 megabytes (MB) of video memory installed in your computer. If your
video adapter does not have 2 MB of video memory, install additional
video memory, or upgrade to a video adapter that has at least 2 MB
of video memory.
To estimate the approximate amount of video memory installed in your
computer:
- Click Start, and then click Run.
- In the Open box, type dxdiag.
- Click OK.
- Click the Display tab.
- Under Device, check the amount of memory listed next
to Approx. Total Memory.
NOTE: If a video accelerator card is installed in your
computer, a Display 1 and a Display 2 tab are available.
Click either tab to check the approximate total memory.
If the approximate total memory is more than 2 MB, and the issue continues
to occur, contact the manufacturer of your video adapter to help determine
how to best resolve this issue.
Download and Install the Graphics.dll Update for Baseball 2000The following file is available for download from the Microsoft Download Center:
Release Date: Mar-07-2000
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.
The Graphics.dll Update for Baseball 2000 includes the following changes:
- Refresh problems with Matrox G400 video cards are now
resolved.
- The missing text problem in Microsoft Windows 2000 is
now resolved.
Obtain and Install an Updated Video Driver
Contact your hardware manufacturer to inquire about how to obtain and
install the latest version of the video driver for your video adapter.
For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base: 65416 Hardware and Software Third-Party Vendor Contact List, A-K
60781 Hardware and Software Third-Party Vendor Contact List, L-P
60782 Hardware and Software Third-Party Vendor Contact List, Q-Z Increase the Hardware Acceleration Setting to Full
To increase the Hardware Acceleration setting to Full:
- Click Start, point to Settings, and then
click Control Panel.
- Double-click System.
- On the Performance tab, click Graphics.
- Move the Hardware Acceleration slider all the way to the
right (the Full acceleration setting).
- Click OK, and then click Close.
- When you are prompted to restart your computer,
click Yes.
Make Sure That the Correct Monitor Is Installed
To make sure that the correct monitor is installed on your computer:
- Click Start, point to Settings, and then
click Control Panel.
- Double-click Display.
- On the Settings tab, click Change Display Type.
NOTE: If you are using Microsoft Windows 95 OEM Service
Release 2 (OSR2), click Advanced Properties, and if you
are using Microsoft Windows 98, click Advanced. - Under Monitor, click Change.
NOTE: If you are using OSR2 or Windows 98, click the
Monitor tab, and then click Change. - In the Manufacturers box, click the manufacturer of
your monitor.
- In the Models box, click the model of your monitor.
- Click OK, click Close, and then
click OK.
- If you are prompted to restart the computer,
click Yes.
Remove Duplicate Monitors
Remove any duplicate monitors that are installed by Windows:
- Click Start, point to Settings, and then
click Control Panel.
- Double-click System.
- On the Device Manager tab, click View
devices by type.
- Click the plus sign (+) next to Monitors to
expand the branch.
- Note the properties for each device that is listed in the
branch. To do this:
- Click a device, and then click Properties.
- Click each tab in the device properties dialog box, and then
record the device information and settings.
- Click OK.
- Click OK, and then close Control Panel.
- Restart Windows in Safe mode. To do this, use the appropriate
method for your version of Microsoft Windows.
Microsoft Windows 98
Restart your computer, press and hold down the CTRL key
when your computer completes the Power On Self Test (POST), and then
select Safe Mode on the Startup menu.
Microsoft Windows 95
Restart the computer. When you see the "Starting Windows 95"
message, press the F8 key, and then select Safe Mode
on the Startup menu. - When Windows starts in Safe mode, click OK.
- Click Start, point to Settings, and then
click Control Panel.
- Double-click System.
- On the Device Manager tab, click View
devices by type.
- Click the plus sign (+) next to Monitors to
expand the branch.
- Verify that there are no changes in the list of devices in
the branch. If you see a device that is not in the list of
devices that you noted in step 5, click the new device, and
then click Remove. Repeat this step for each device
in the branch that is not in the list of devices that you
noted in step 5.
NOTE: If you see new copies of a device that is in the list
of devices you noted in step 5, check the properties of each copy of
the device. If the properties for the device match the properties
that you recorded, keep the device. If the properties for the device
do not match the properties you recorded, remove the device. - Click OK.
- When you are prompted to restart the computer, do so.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Baseball 2000.
Modification Type: | Minor | Last Reviewed: | 8/5/2004 |
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Keywords: | kbdownload kbbug kbdisplay kbenv kberrmsg kbfile kbfix KB234199 |
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