SBCM: Years in Select Invoice Time Combo Box Unchanged If Regional Settings Changed During Session (234128)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Small Business Customer Manager, when used with:
    • Microsoft Office 2000 Small Business Tools

This article was previously published under Q234128

SYMPTOMS

In Small Business Customer Manager and the Sales by Period view, you notice that the number of digits for Years shown in the Select Invoice Time box are not the same date format as indicated in the Regional Settings Properties dialog box in Control Panel.

CAUSE

You changed the Date setting in Regional Settings Properties dialog box to show 4 or 2 digits while Small Business Customer Manager was running. Small Business Customer Manager is not aware of the change in the Regional Settings Properties box.

NOTE: In Microsoft Windows 2000, the Regional Settings Properties dialog box is called the Regional Options dialog box, and some of the tabs and options may have slightly different names.

RESOLUTION

For the change to take effect, close and reopen Small Business Customer Manager.

MORE INFORMATION

Small Business Customer Manager is an Access run-time application located on Disc 2 of Microsoft Office 2000 Professional, Microsoft Office 2000 Developer, and Microsoft Office 2000 Premium. To install Small Business Customer Manager, run Setup.exe on Disc 2.

Steps to Reproduce Behavior

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Regional Settings, and then click the Date tab.
  3. Set the Short date style box to have a two-digit year by typing m/d/yy, and then click OK.

    NOTE: The Short date box may already have this setting.
  4. Start the Small Business Customer Manager.
  5. On the custom command bar, click Sales, and then click By Period. The Sales by Period view opens.
  6. Under Narrow Your Choice, click the arrow for the Select Invoice Time (All) box. Note that the choices in the combo box for Years has two digits, as expected.
  7. Leave the Sales by Period view open, and do not close Small Business Customer Manager.
  8. In Control Panel, double-click Regional Settings, and then click the Date tab.
  9. In the Short date style box, type m/d/yyyy, and then click OK. This sets the regional settings to have a four-digit year.
  10. Return to Small Business Customer Manager, and again click the arrow for the Select Invoice Time (All) box. Note that the choices in the list for Years still have two digits. If you quit and restart Small Business Customer Manager at this point, the combo box in the Sales by Period view will contain four-digit years.

Modification Type:MajorLast Reviewed:6/28/2004
Keywords:kbprb kbsbt KB234128