XIMS: Chat Service Ends Connection When Client Does Not Send Data for 10 Minutes (233512)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q233512

SYMPTOMS

If you do not send data for 10 minutes while you are connected to a Microsoft Exchange Chat Service computer, the server may end the connection. This problem only occurs if you are running version 5.5.2577.0 or later of the Chatsvc.exe file on the server.

CAUSE

If a connection to the server remains inactive for a long period of time, the server attempts to obtain a reply from the client. If the server does not receive a reply, it tries a second time. If the server still does not receive a reply, it ends the connection.

When earlier versions of the Chat Service receive data from the client, they restart the above process and do not attempt to obtain a reply from the client until the connection has been inactive for a long period of time again. Later versions of the Chat Service also restart the above process when the server sends data to the client. As a result of this behavior, the client may send data to the server less frequently. If the client does not send any data to the server for 10 minutes, the server may end the connection.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

The English version of this fix should have the following file attributes or later:

Component: Chat Service

File nameVersion
Chatsvc.exe5.5.2621.0

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE EXC55SP3Fix kbbug kbfix KB233512