Cannot Undock Notebook Computer with LS-120 Removable Drive in the Docking Station (231942)



The information in this article applies to:

  • Microsoft Windows 95 OEM Service Release 2.1
  • Microsoft Windows 95 OEM Service Release 2.5

This article was previously published under Q231942

SYMPTOMS

You cannot undock a notebook computer when an LS-120 IDE Floptical drive is installed in the docking station.

CAUSE

The Input Output Supervisor (IOS) query remove request does not succeed on the suspend operation when the system is attempting to undock because the device is of type DCB_TYPE_floppy.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date      Time    Version      Size    File name
   ------------------------------------------------
   04/12/99  09:18p  4.00.1114    68,962  Ios.vxd
				
NOTE: You must install the AMD-K6-2 update before installing this hotfix.
To work around this problem, shut down the computer before you undock the notebook computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about the AMD-K6-2 Update, please see the following article in the Microsoft Knowledge Base:

192841 Difficulties Using AMD K6-2 or Athlon Central Processing Unit


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbHardware kbprb kbQFE KB231942