XIMS: Internet Mail Service Fails to Start and Logs 4070 and 4131 Errors (231737)



The information in this article applies to:

  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0
  • Microsoft Exchange Server 5.5

This article was previously published under Q231737

SYMPTOMS

The Internet Mail Service does not start and causes inbound mail to stop flowing. You may find that there is plenty of disk space. Restarting the Internet Mail Service temporarily resolves the issue until the mail stops flowing again. The application event log may report the following error messages from the MSExchangeIMC service:
4070: An error occurred while opening a temporary message file. Verify that the message spool directories are configured correctly and are readable by the Internet Mail Service.

4131: An unexpected error occurred in the Internet Mail Service. Information about this error is stored in the data portion of this event.

CAUSE

An application or a user may have deleted the Exchsrvr\Imcdata\In directory. When permissions on the C:\Exchsrvr\Imcdata\In directory are not set to Read Only, the directory may be deleted or renamed by any outside agent during Internet Mail Service operation.

RESOLUTION

  1. Verify that the C:\Exchsrvr\Imcdata\In directory exists before restarting the Internet Mail Service.
  2. Recreate the directory if necessary.
  3. Set the Everyone group's access level to the Imcdata directory to Read Only, and restart the Internet Mail Service.

MORE INFORMATION

If you notice that the directory is being deleted, you may want to enable auditing to determine the source of the activity. For additional information, see the following article in the Microsoft Knowledge Base:

146791 XFOR: IMC Cannot Receive Message with Missing Folder


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbpending kbprb KB231737