Client certificates may not appear in Internet Explorer for Windows 95/98 (231718)
The information in this article applies to:
- Microsoft Internet Explorer 4.01 for Windows 98 SP 2
- Microsoft Internet Explorer 4.01 for Windows 95 SP 1
- Microsoft Internet Explorer 4.01 for Windows 95 SP 2
- Microsoft Internet Explorer 4.0 for Windows 95
- the operating system: Microsoft Windows 98
This article was previously published under Q231718 SYMPTOMS
When you attempt to visit a Web site that requires a client certificate, it may appear that your client certificates are missing, and you may receive the following error message:
Client Authentication
Identification
The Web site you want to view requests identification. Select the certificate to use when connecting.
The list of certificates may be blank, indicating that the client certificate are not present. If you click OK or Cancel, you may receive the following error message:
HTTP Error 403
403.7 Forbidden: Client certificate required
This error occurs when the resource you are attempting to access requires your browser to have a client Secure Socket Layer (SSL) certificate that the server recognizes. This is used for authenticating you as a valid user of the resource.
Please contact the Web server's administrator to obtain a valid client certificate.
CAUSE
This behavior can occur for any of the following reasons:
- You clicked Cancel in the Windows Log On dialog box. Internet Explorer and Microsoft Outlook Express are unable to locate your personal certificate information and are therefore unable to gain access to Web sites that require the certificate. You also cannot send digitally signed messages or decrypt messages received.
- Your Username.pwl file is damaged, missing, or renamed.
NOTE: If you installed Windows 95 Service Pack 1, there is a known issue that can cause the .pwl file to become damaged. For additional information about this issue and its resolution, please see the following article in the Microsoft Knowledge Base:
132807 Enhanced Encryption for Windows 95 Password Cache
- You may have attempted to install more than 16 personal certificates.
RESOLUTION
To resolve this issue, use the appropriate method.
Method 1
Log on to Windows when you are prompted. If you are the only person using the computer and you do not want to be prompted to log on to Windows every time you start your computer, you can leave the password field blank. When you are prompted to confirm the password, leave that field blank as well.
Method 2
Export the personal certificate before you rename or delete your
Username.pwl file, and then import the certificate after creating a new .pwl file. If you are unable to export the certificate, you need to obtain another personal certificate.
Modification Type: | Minor | Last Reviewed: | 4/13/2005 |
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Keywords: | kbenv kberrmsg kbprb KB231718 |
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