XFOR: Japanese Messages May Have Garbled File Names, Subject, or Message Text (230782)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0, when used with:
    • Microsoft Commercial Internet System 2.0
    • Microsoft Commercial Internet System 2.5

This article was previously published under Q230782

SYMPTOMS

After you download a message with an IMAP client, the message may have garbled attachment names, subject lines, or message text. Some IMAP clients may stop working on receiving such messages.

CAUSE

This situation arises on English and Japanese versions of an Microsoft Commercial Internet System (MCIS) server. If a message arrives for an IMAP client with attachment names, subject lines, or message text in ISO-2022-JP, text marked as being in ISO-2022-JP is saved correctly in the MCIS file structure in 7-bit ASCII, which looks like:
Content-Type: image/bmp;
	name="=?iso-2022-jp?B?GyRCQmdBcDg2JE5JdxsoQi5ibXA=?="
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
	filename="=?iso-2022-jp?B?GyRCQmdBcDg2JE5JdxsoQi5ibXA=?="
				
When an IMAP client fetches this message, the ASCII text is converted to ShiftJIS (8-bit data), and sent over the network. The receiving client may not have the ability to handle 8-bit data in a FETCH command. Internet protocols (RFC 2045) generally prohibit sending 8-bit data in a FETCH response.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

File nameVersion
Imapsvc.dll5.5.1877.25


NOTE: The hotfix should be placed on the MCIS server.
This hotfix is included in article 274448. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

274448 XIMS: New Microsoft Commercial Internet System Internet Message Access Protocol Service Fixes Available

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commercial Internet System version 2.0.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB230782