Internet Explorer Administration Kit Restrictions Are Not Applied Correctly in Windows NT (230771)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0

This article was previously published under Q230771

SYMPTOMS

After you install Internet Explorer and configure Internet restrictions on a computer running Windows NT, you cannot use the Internet Explorer Administration Kit (IEAK) to apply Internet restrictions when other users log on to that computer with only user-mode permissions.

CAUSE

This behavior can occur if you do not have Administrator permissions for the computer. This is because of a security change in Windows NT regarding the registry. When branding is attempted during a new user logon attempt, the attempt is unsuccessful and the error message is displayed if the user does not have Administrator permissions.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 4.01 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:

DateSizeFile namePlatform
05/07/99131,2962292.exex86
02/24/9949,248Admparse.dllx86
05/06/9949,248Iedkcs32.dllx86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When you request this hotfix, make sure you obtain the version of the hotfix that matches your version of Internet Explorer.

To install the hotfix, use the following steps:

NOTE: You should only use 2292.exe in the IEAK package.
  1. Start the IEAK creation wizard, update all the downloaded components, and then quit the wizard.
  2. Manually update the Iedkcs32.dll file, with the hotfix .dll file provided (located in the Ieak\Iebin\Optional folder).
  3. Manually update the Amdparse.dll file, with the hotfix .dll file provided (located in the Ieak folder).
  4. Start the IEAK creation wizard, and disable the AVS Checking option in advanced options.
  5. During the IEAK build process, add the 2292.exe hotfix self installer as a custom component, and use the following command-line parameters:

    /q:1 /n:v /r:n.

  6. Test the IEAK package.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbsetup KB230771