XFOR: Internet Mail Service Failed to Deliver Message, Error 4117 (230250)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q230250 SYMPTOMS
The Internet Mail Service may fail to deliver inbound Internet messages if the Character Sets setting is improperly configured. An Event Log entry similar to the following appears in the Windows NT application log:
Event ID: 4117
Source: MSExchangeIMC
Description:
An error was returned from the messaging software the
Internet Mail Service uses to process messages on the
Microsoft Exchange Server. As a result, the message in
spool file Jtmrmaqv failed to be delivered. The message
has been moved to the IMCDATA\IN\ARCHIVE directory.
The spool file name may vary from computer to computer.
CAUSE
The Character Sets setting on Internet Mail Service is improperly configured. This usually happens if the default Character Sets setting was changed.
The setting is on the Internet Mail tab of Internet Mail Service Properties page. The default setting for either MIME or Non-MIME is "Western European (ISO-8859-1)."
This can also occur if antivirus software that is not "Exchange aware" is running on the system. Use of antivirus software that is not "Exchange aware" is highly discouraged.
RESOLUTION
To resolve this problem, you need to reconfigure the Character Sets setting using the following procedure:
- Check the 4117 event, locate the spool file name ("Jtmrmaqv" in the above example).
- Open this file under Exchsrvr\Imcdata\In\Archive with Notepad.exe.
- The majority of this file is in plain text format. It contains the header and body of the inbound message to be delivered. The character set of the message is included in lines similar to:
Content-Type: text/plain;
charset="ISO-8859-1"
- Open the Exchange Server Administrator program, and open the properties for the Internet Mail Service.
- On the Internet Mail tab, reset the character sets to correspond with the character set name you find in step 3. (If this problem only happens to certain domains, you may prefer per-domain setting by clicking the E-Mail Domain button.)
- Stop and restart Internet Mail Service.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
---|
Keywords: | kbprb KB230250 |
---|
|