Time-Out Errors Sending Web Page Requests to an ICS Host (229890)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q229890
For a Microsoft Windows XP version of this article, see 311070.

SYMPTOMS

When you connect to the Internet using Internet Connection Sharing (ICS), you may receive a time-out error message.

CAUSE

This error message can occur if an Internet connection takes longer to connect than the time-out period specified in the client's request. For example, if the phone line is busy, an Internet connection cannot be established and the initial Internet request times out.

RESOLUTION

To resolve this issue, apply one of the following options where applicable:

Re-send the Internet request. To do this, press F5 in Internet Explorer. Establish the connection manually using the ICS host computer.Add the string value "NameSvrQueryTimeout" to the HKEY_LOCAL_MACHINE\System \CurrentControlSet\Services\VxD\MSTCP registry key with a data of "10000" (10000 = 10 seconds) to allow the Host computer to finish connecting to the internet. Adjust the number as needed.

MORE INFORMATION

The amount of time an Internet program takes to time out for a request sent to the Internet depends on a number of factors, including the program's design. ICS, when first started, sends a DHCP Discover packet to verify that it is the only DHCP allocator on the LAN. This prevents the ICS host from forwarding any Internet requests to the Internet for about 60 seconds after the ICS host has rebooted and logged on to Windows.

For additional information about TCP/IP, please see the following article in the Microsoft Knowledge Base:

158474 Windows TCP/IP Registry Entries


Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kbDialUp kbFAQ kbprb KB229890