Dtcxatm.log File Grows Unexpectedly Large (229613)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q229613

SYMPTOMS

When Microsoft SQL Server is used with an XA-compliant resource manager (for example, Oracle, IMB DB2, or Informix), the Dtcxatm.log file can grow quite large. For example, it is possible for files to reach several hundred MB in size. Therfore, when recovery is performed, Microsoft Distributed Transaction Coordinator (DTC) reads through the entire log file. This can lead to extremely long recovery times.

CAUSE

This problem occurs because of an error in the way that space is reclaimed in the log file.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack

The following files were modified in Windows NT 4.0 Service Pack 5 to fix this problem:

NameDateTimeSize
Dtccm.dll4/22/9912:04p110,864
Dtcxatm.dll4/22/9912:04p162,064
Logmgr.dll4/22/9912:04p59,664
Msdtcprx.dll4/22/9912:04p189,712
Msdtctm.dll4/22/9912:04p456,976
Mtxoci.dll4/22/9912:04p69,904

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 5.

Modification Type:MajorLast Reviewed:10/16/2002
Keywords:kbbug kbQFE KB229613