NetMeeting Registers Wrong IP Address with ILS Server When Windows CE Device Is Connected (229060)



The information in this article applies to:

  • Microsoft NetMeeting 2.1 for Windows NT 4.0
  • Microsoft NetMeeting 2.1 for Windows 98
  • Microsoft NetMeeting 2.1 for Windows 95

This article was previously published under Q229060

SYMPTOMS

A NetMeeting client who has a Microsoft Windows CE-based device configured and connected to a serial port (a direct cable connection) may be unable to host a meeting. Any client who tries to call this NetMeeting client from the Internet Locator server (ILS) directory may receive the following error message:
The person you called is not able to accept Microsoft NetMeeting calls.
Would you like to send this person a message?

CAUSE

When a NetMeeting client starts, it sends a packet of data to the ILS server to which it is configured to log on. This packet contains the Lightweight Directory Access Protocol (LDAP) attributes the server requires. One of the attributes in this packet is the Internet Protocol (IP) address of the local computer. This IP address is then used to establish a connection between computers when another client tries to join or create a meeting with this NetMeeting user.

If a Windows CE-based device is connected to the computer on a serial port, it uses the Dial-Up Networking (DUN) Direct Cable Connection adapter. When this adapter is used, it is assigned a "dummy" IP address of 192.168.55.1. This "dummy" IP address, along with the local computer's true IP address, makes the computer multi-homed.

When NetMeeting is started with a Windows CE-based device connected to a serial port, the IP address of the DUN adapter, rather than that of the local computer's IP address, is registered in the LDAP server. As a result, any NetMeeting client trying to join or establish a meeting with this user is given the wrong or "dummy" IP address from the ILS server and the connection does not work.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next NetMeeting 2.1 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date      Time    Version      Size    File name     Platform
   -------------------------------------------------------------
   4/1/99    11:09PM 5.0.1577     90,384  Wldap32.dll   i386<BR/>
   4/1/99    11:41PM 4.3.2208     66,832  Ils.dll       i386
				

To work around this problem, use any of the following methods:
  • Disconnect the Windows CE-based device and restart the NetMeeting client.
  • On the Call menu, click New Call. In the Call Using box, click Network (TCP/IP). In the Address box, type the user's computer name or IP address.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbenv kberrmsg kbfix kbprb kbQFE KB229060