Cannot Log On to Web Site Requiring Case-Sensitive User Name (228914)



The information in this article applies to:

  • Microsoft Internet Explorer 5.01, when used with:
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 95
  • Microsoft Internet Explorer 5.0, when used with:
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 95

This article was previously published under Q228914

SYMPTOMS

After the installation of Internet Explorer 5, you may not be able to log on to a Web site that requires a user name and password to be entered on the "http://" address line. For example,

http://USERNAME:password@www.mywebsite.com

CAUSE

This behavior can occur because the user name portion of the Web address (or URL) is being changed to lowercase. If the site requires a case-sensitive user name, validation may not succeed because Internet Explorer sends the user name credentials in lowercase. The password portion is unaffected and retains its case.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

By default, MS04-004 disables user:pass support in HTTP URLs.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

832894 "The data is invalid" could indicate a corrupt metabase


Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbprb KB228914