Access Violation When Using Aventail Connect with SOCKS Proxy (228837)



The information in this article applies to:

  • Microsoft Proxy Server 2.0

This article was previously published under Q228837

SYMPTOMS

When you attempt to use the Aventail Connect client (version 2.41 or later) through an Microsoft SOCKS Proxy service, an Access Violation error occurs during the connection in Inetinfo.exe.

Note: Other applications may also cause this symptom to occur, but this has only been recognized in conjunction with the Aventail Connect client.

CAUSE

This error occurs due to an inbound connection that is being matched against an existing session that has not yet been initialized in the SOCKS Proxy service. This results in the SOCKS Proxy service attempting to use the partially-established session (or the partially torn-down session) and receiving an incorrect pointer.

RESOLUTION

To resolve this problem, obtain Microsoft Proxy Server 2.0 Service Pack 1. For additional information about Service Pack 1, please see the following article in the Microsoft Knowledge Base:

238375 Proxy Server 2.0 Service Pack 1: List of Fixes

STATUS

Microsoft has confirmed that this is a problem in Proxy Server 2.0.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB228837