Error Message: "Error Writing to <printer port>" When Printing (228542)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Workstation 4.0 SP1
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP3
- Microsoft Windows NT Workstation 4.0 SP4
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Server 4.0 SP1
- Microsoft Windows NT Server 4.0 SP2
- Microsoft Windows NT Server 4.0 SP3
- Microsoft Windows NT Server 4.0 SP4
- Microsoft Windows NT Server, Enterprise Edition 4.0
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
This article was previously published under Q228542 SYMPTOMS
When you attempt to send a print job to a Windows NT-based print server, the following error message may be displayed:
Error writing to <printer port> for document printer <print job>, the port is unknown.
The error message is not displayed if you log on to the computer using the Administrator account or with another account that has administrator privileges.
CAUSE
This problem occurs because the permissions for the %SystemRoot%\System32\Spool folder does not contain the "Everyone" group.
RESOLUTION
To resolve this problem:
- Click Start, point to Programs, and then click Windows NT Explorer.
- Right-click the %SystemRoot%\System32\Spool folder, and then click Properties.
- Click Security, and then click Permissions.
- Click Add, click the domain the print server belongs to in the List Names From box, double-click Everyone in the Names box, and then click OK.
- Click Everyone in the Name box, click Change in the Type of Access box, click OK, and then click OK again.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 5/14/2003 |
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Keywords: | kbenv kberrmsg kbnetwork kbprb kbprint KB228542 |
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