Lotus Programs Cannot Send Faxes from Outlook (228493)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q228493

SYMPTOMS

When you fax from Microsoft Outlook by using Lotus programs in a BackOffice Small Business Server (SBS) environment may result in the following symptoms:
  • Faxes may not be rendered and sent successfully.
  • Outlook clients may receive the following non-delivery receipt (NDR):
    From: System Administrator
    To: Outlook User
    Subject: 123(.123 file name)

    Your message did not reach some or all of the intended recipients.

CAUSE

For the fax mail transport to be able to fax an attachment, there must be a program with the ability to print or render the file. This program must be registered with the "printto" action. Without the "printto" action association, you cannot fax the file.

Some programs can print to a specified printer from the command line but they do not set the "printto" action at during Setup. In this case, you can create the "printto" association by using the same command line that the program uses. Other programs may not support command-line printing; if they do not, you cannot send attachments to fax recipients from Outlook.

RESOLUTION

On each client workstation that uses the program, check to see if the "printto" action is associated with the program that you are using. To do this, start Windows Explorer, click Folder Options (or Options) on the View menu, and then click the File Types tab. If the program does not have the "printto" action associated with it, and the program does support command-line printing, add the "printto" action by following these steps:
  1. Start Windows Explorer, click Folder Options (or Options) on the View menu, and then click the File Types tab.
  2. In the Registered File Types box, click the program, and then click Edit.
  3. Under Actions, click New.
  4. In the Action box, type printto.
  5. In the Application used to perform action box, type command line to print, where command line to print is the appropriate syntax for the program you are using. Consult the program's documentation or manufacturer for information about the appropriate command line.
  6. Click OK, click OK, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Attachments are faxed from Outlook by calling a shell function that checks the registry to see how to print the specified file. The shell uses the "printto" action to do this. Printing is performed either by running a program that takes the document path and the printer as parameters and knows how to silently print the file to that printer, or by using Dynamic Data Exchange (DDE) to start the program and pass the data.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

198577 Only Some E-mail Attachments Can Be Faxed from Outlook to SBS


Modification Type:MajorLast Reviewed:11/19/2003
Keywords:kb3rdparty kbbug kbenv kbnofix KB228493