You receive the "Files required for this feature have been removed or have become corrupted" error message when you try to open the Contact Manager tool in Money (228043)



The information in this article applies to:

  • Microsoft Money Small Business 2006
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2004 Small Business
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money Deluxe & Business 2002
  • Microsoft Money 2001 Deluxe and Business
  • Microsoft Money 2000 Business and Personal
  • Microsoft Money 99 Business and Personal

This article was previously published under Q228043

SYMPTOMS

When you try to open the Contact Manager tool in Microsoft Money 99 Personal and Business or synchronize the address book, you may receive the following error message:
Files required for this feature have been removed or have become corrupted. You need to run Money Setup again to install this feature.

CAUSE

This issue may occur if any of the following conditions are true:
  • The Wab.exe file is missing.
  • Your Windows Address Book file is damaged.
  • Microsoft Outlook Express is no longer installed on your computer.

RESOLUTION

To troubleshoot this issue, use the following methods.

Rename and replace the Wab.exe file

If you experience this issue when you try to open the Contact Manager tool, rename and replace the Wab.exe file. To do this:
  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Named box, type wab.exe.
  3. In the Look In box, click My Computer, and then click Find Now.
  4. In the list of found files, right-click the Wab.exe file, and then click Rename.
  5. Type wab.old, and then press ENTER.
  6. Close the Find: Files Named Wab.exe window.
  7. Extract a new copy of the Wab.exe file. If you are using Microsoft Windows 95 or Microsoft Internet Explorer 5, reinstall Outlook Express.

    If you are using Microsoft Windows 98 and Microsoft Internet Explorer 4.x, extract a new copy of the Wab.exe file from the Windows 98 CD-ROM. To do this:
    1. Click Start, and then click Run.
    2. In the Open box, type sfc, and then click OK.
    3. Click Extract one file from installation disk, and then type wab.exe in the Specify the system file you would like to restore box.
    4. In the Restore From box, type the following line

      cd-rom:\Win98

      where cd-rom is the drive letter of the CD-ROM drive that contains the Windows 98 CD-ROM.
    5. In the Destination Folder box, type the following line, and then click OK:

      C:\Program Files\Outlook Express

  8. Restart the computer.
If the issue continues to occur, proceed to the "Remove and Reinstall Outlook Express" method later in this article.

Rename and replace the Mnywab.dll file

If you experience this issue when you attempt to synchronize the address book, rename and replace the Mnywab.dll file. To do this:
  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Named box, type mnywab.dll.
  3. In the Look In box, click My Computer, and then click Find Now.
  4. In the list of found files, right-click the Mnywab.dll file, and then click Rename.
  5. Type mnywab.old, and then press ENTER.
  6. Close the Find: Files Named Mnywab.dll window.
  7. Click Start, point to Programs, and then click MS-DOS Prompt.
  8. At the command prompt, type the following line, and then press ENTER

    extract cd-rom:\money99\money99.1 Mnywab.dll /L "drive:\Program Files\Microsoft Money"

    where cd-rom is the drive letter of the CD-ROM drive, and drive is the drive letter of the hard disk on which Money is installed.
  9. At the command prompt, type exit and then press ENTER to return to Windows.
For additional information about how to extract original compressed Windows files, please see the following article in the Microsoft Knowledge Base:

129605 How To Extract Original Compressed Windows Files

Remove and reinstall Microsoft Outlook Express

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the Install/Uninstall tab.
  4. In the list of installed programs, click Microsoft Outlook Express, and then click Add/Remove.
  5. Follow the instructions on the screen to remove Outlook Express.
  6. Restart the computer.
  7. To reinstall Outlook Express, visit the Microsoft Windows Update page at the following Microsoft Web site:

Modification Type:MajorLast Reviewed:7/2/2005
Keywords:kbenv kberrmsg kbinterop kbprb KB228043