XCLN: Dr. Watson Occurs Viewing Outlook Calendar with Schedule+ 7.x (227854)



The information in this article applies to:

  • Microsoft Schedule+ 7.0, when used with:
    • the operating system: Microsoft Windows NT
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft Schedule+ 7.5, when used with:
    • the operating system: Microsoft Windows NT
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98

This article was previously published under Q227854

SYMPTOMS

One of the following error messages may occur while accessing a Microsoft Outlook user's Calendar using Microsoft Schedule+ 7.x with the Microsoft Schedule+ Transport DLL (Msoutl32.dll):
An application error has occurred and an application error log is being generated.
Schdpl32.exe
Exception: access violation (0xc0000005), Address: 0x1001729a
-or-
An application error has occurred and an application error log is being generated.
Schdpl32.exe
Exception: access violation (0xc0000005), Address: 0x1001729a
In other situations, an application error does not occur. However, the Microsoft Outlook user's schedule appears empty.

CAUSE

The Microsoft Outlook user's Calendar folder contains a corrupt recurring appointment. Specifically, the appointment is missing one or more required MAPI properties.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Msoutl32.dll

Msoutl32.dll8.20.2588.0

WORKAROUND

To correct the corrupt recurring appointments, perform the following steps:
  1. From the Microsoft Outlook user's mailbox, select the Calendar folder.
  2. On the View menu, click Current View, and click Recurring Appointments. This will display all recurring appointments categorized by their recurrence pattern (Daily, Weekly, Monthly). You may see one or more recurrence patterns with a value of (none).
  3. For each appointment in the (none) category, perform the following actions to reset the recurrence patterns and re-write the necessary MAPI properties to the appointment:
    1. Open the appointment.
    2. Click the Recurrence button on the toolbar.
    3. Click OK.
    4. Click the Save and Close button on the toolbar.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Schedule+ 7.0 and 7.5.

MORE INFORMATION

If you are using version 8.2.1.4308 of Msoutl32.dll, you may receive a Dr. Watson in Schdpl32.exe or Exchng32.exe, as shown above.

If you are using version 8.1.2367.0 of Msoutl32.dll, the user's schedule is displayed, but you are unable to see any appointments in the Microsoft Outlook Calendar.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB227854