ACC: Error Message Using OutputTo to Output a Report to Another Format (226526)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Access 2002

This article was previously published under Q226526
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

SYMPTOMS

When you use the OutputTo action or method to output a report to another format, you receive one of the following errors:
Run-time error '2024':

The report snapshot was not created because you do not have enough free disk space for temporary work files.

-or-

Run-time error '2302':

Microsoft Access can't save the output data to the file you've selected.

-or-

Run-time error '2282':

The formats that enable you to output data as a Microsoft Excel, rich-text format, MS-DOS text, or HTML file are missing from the Windows Registry.

CAUSE

You may receive one of the errors that is mentioned in the "Symptoms" section if any one of the following is true of the OutputFile argument of the OutputTo action or method:
  • You did not specify a file name.

    -or-
  • The file name that you supplied contains an invalid character (!@#$%^&*():;).

    -or-
  • The path that you specify does not exist.

RESOLUTION

To work around this problem, do the following:
  • Modify the OutputFile argument of the OutputTo action or method to include a file name.
  • Make sure that the file name does not include any invalid characters.
  • Make sure that you are using the correct path.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Open the sample database Northwind.mdb.
  2. Create a new module and type the following procedure:
    Sub OutputSnapshot()
       DoCmd.OutputTo acOutputReport, "Alphabetical List of Products", _
        acFormatSNP, "C:\My Documents\", True
    End Sub
    						
    NOTE: This procedure assumes that you have a "My Documents" folder on the drive C.
  3. Press F5 to run the procedure.

    Note that you receive the first error listed in the "Symptoms" section.

REFERENCES

For more information about the OutputTo action, click Microsoft Access Help on the Help menu, type OutputTo action in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

Modification Type:MajorLast Reviewed:6/24/2004
Keywords:kberrmsg kbprb KB226526