Err Msg: "2140" or "4014" Internet Mail Service Does Not Work After You Install DOD Router (226123)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q226123

SYMPTOMS

When you configure per-domain routing in the Microsoft Exchange Server Internet Mail Service on a BackOffice Small Business Server (SBS) computer and you change the network configuration to reflect a dial-on-demand (DOD) router, error messages similar to the following may be displayed in the event log:
2140

-or-

4014

CAUSE

This behavior occurs if the DOD router takes longer than 10 seconds to make a connection to the Internet Service Provider to resolve the Domain Name System (DNS) query.

RESOLUTION

To resolve this problem, do either of the following:
  • Correct or remove the erroneous per-domain routing entry, which is listed in the event log.
  • In the Exchange Server Administrator program, expand the Connections container, double-click Internet Mail Service to open the properties, and then click the Connections tab. Click to clear the Use DNS check box, click Forward messages to host, and then type a relay agent in that field.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Exchange Server 5.5 Service Pack 2.

MORE INFORMATION

If you experience this problem in:
  • Exchange Server 5.5, then apply Exchange Server 5.5 Service Pack 2.
  • SBS 4.x, then upgrade to SBS 4.5.
  • SBS 4.5, then reapply Exchange Server 5.5 Service Pack 2 (which is found in the Sbs45CD3\ExchSrvr.sp2 folder.

Modification Type:MajorLast Reviewed:10/27/2003
Keywords:kbbug kbfix KB226123