Microsoft IntelliMouse Is Not Detected or Causes Hang in Windows 2000 (226015)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q226015

SYMPTOMS

If there is a Microsoft IntelliMouse connected to your computer, the IntelliMouse may not be detected or your computer may stop responding (hang).

CAUSE

This behavior can occur for any of the following reasons:
  • The wheel mouse is an Original Equipment Manufacturer (OEM) wheel mouse other than the mouse that was originally included with your computer.
  • The wheel mouse is connected to a switch box with an unreliable 8042 port.
The Microsoft retail wheel mouse has additional circuitry that allows it to be queried by the operating system. If a wheel mouse is connected to the computer, it returns a string identifying itself as such. Note that running the query does not enable the wheel mouse; it simply lets the operating system know that a wheel mouse is attached. Running the query is safe; it does not cause the computer to hang.

RESOLUTION

To resolve this issue, use any of the following methods:
  • Use an OEM wheel mouse that has been tested and confirmed to work with your computer.
  • Use a Microsoft retail wheel mouse that contains the additional circuitry.
Also, check the Advanced Settings tab in the mouse's properties in Device Manager. Make sure that the enabling code is not being run by verifying that Assume Wheel Is Present is selected in the Wheel Detection box.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:5/14/2003
Keywords:kbHardware kbprb KB226015