Program Is Not Installed Correctly Using Sysdiff.exe (225640)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Professional
- Microsoft Windows NT Server 4.0
This article was previously published under Q225640 SYMPTOMS
A program may not be installed properly using Sysdiff.exe.
CAUSE
A program has one or more associated .ini files. The .ini files contain multiple section headers that are not in alphabetical order. Sysdiff.exe alphabetizes the section headers in the .ini files, keeping the contents of each section with the appropriate section header. Therefore, the section headers may not be in the same order as in a successful installation. This may cause the installation of the program not to succeed.
RESOLUTION
To work around this behavior, create a batch file that copies the correct, non-alphabetized .ini files over the incorrect alphabetized files. Use the SYSDIFF /APPLY command to install the program, then run the batch file to replace the alphabetized .ini files with the correct non-alphabetized files.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 5/14/2003 |
---|
Keywords: | kbenv kbprb kbsetup KB225640 |
---|
|