The Content Index Service May Not Work if You Uninstall SQL Server 7.0 (225393)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.5
This article was previously published under Q225393 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If you uninstall Microsoft SQL Server 7.0 from your computer running Small Business Server (SBS) 4.5, the Content Index service may not start. You may also receive the following error message:
The Dynamic Link library Query.dll could not be found in the specified path Path.
NOTE: During the uninstallation, you are prompted to keep shared files or delete them. The error message is displayed for either action.
CAUSE
This behavior occurs when one or more programs do not correctly increment the usage counters for the Qperf.dll and Query.dll files. The uninstallation process for SQL Server 7.0 removes the Query.dll and Qperf.dll files.
RESOLUTION
To resolve this problem, extract the Query.dll and Qperf.dll files from Is20.cab on SBS 4.5 CD-ROM 2:
- Locate Is20.cab in the CD2\Ntoptpak\En\x86\Winnt.srv\ path.
- Locate the Query.dll and Qperf.dll files and put them in the C:\Winnt.sbs\System32 folder.
- Restart the Content Index service.
STATUSMicrosoft has confirmed that this is a problem in BackOffice Small Business Server 4.5.
Modification Type: | Major | Last Reviewed: | 8/6/2002 |
---|
Keywords: | kbbug KB225393 |
---|
|