Removing Proxy Client Does Not Remove WSP Client Icon from Control Panel (225292)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q225292

SYMPTOMS

If you remove the Winsock Proxy (WSP) Client tool from a BackOffice Small Business Server (SBS) client computer using the Control Panel Add/Remove Programs tool or through the Uninstall program in the WSP client, the WSP Client icon is not removed from Control Panel, even though the program is no longer functional.

When you try to open the WSP Client tool, the following error message is displayed:
WinSock Proxy client is not installed properly.

CAUSE

This behavior can occur for any of the following reasons:
  • The WSP Client Uninstall program did not remove the Wspcpl32.cpl file.
  • Windows NT Service Pack 4 or later has been install or reinstalled and the Winsock Proxy client has not been reinstalled.

RESOLUTION

To resolve this issue:
  1. Locate the Systemroot\System32\Wspcpl32.cpl file on your hard disk drive.
  2. Delete or rename the Wspcpl32.cpl file.
  3. Close, then reopen Control Panel.
The WSP Client icon is no longer present.

STATUS

Microsoft has confirmed that this is a problem in Microsoft BackOffice Small Business Server 4.0, 4.0a, 4.5.

Modification Type:MajorLast Reviewed:11/19/2003
Keywords:kbbug kbenv kbnofix KB225292