SBCM: ErrMsg "Could not load an object..." Opening Contact (223845)



The information in this article applies to:

  • Microsoft Small Business Customer Manager, when used with:
    • Microsoft Office 2000 Small Business Tools
  • Microsoft Outlook 2000

This article was previously published under Q223845

SYMPTOMS

When you open any of your Outlook contacts, you may receive the following error messages:
Microsoft Forms

Could not load an object because it is not available on this machine.
When you click OK, you receive this second message:
Script Error

Object does not support this property or method: 'pageSBE.DataGrid1'
Line No:11

CAUSE

The above error occurs if you open an Outlook contact that has been imported into a Small Business Customer Manager (SBCM) database from a computer that does not have SBCM installed. The computer without SBCM lacks the DataGrid control, which is included in Msdatgrd.ocx. This control is installed when you install the SBCM or the Small Business Forms Manager (SBFM) from the Microsoft Office 2000 CD-ROM2.

WORKAROUND

Click OK to each error and the contacts open. You can ignore the errors while using Outlook on a computer without SBCM installed, or you can install SBCM or SBFM from the Office 2000 CD-ROM 2. If you cannot or do not want to install SBCM, follow these steps to export all contacts from your Contacts folder to a Comma Separated Values (Windows) (CSV) format file, and then to import them back into the Contacts folder after you have deleted all the contacts:
  1. Export all your contacts to a CSV file named "Contacts.csv" on your desktop. (You will use this file to import your contacts later.) To do so:
    1. Start Outlook.
    2. Click the Contacts folder.
    3. Click File Menu, and then click Import and Export.
    4. Click Export to a file, and then click Next.
    5. Click Comma Separated Values (Windows) and then click Next.
    6. Click the Contacts folder under the mailbox tree of folders, and then click Next.
    7. Type a file name such as "Contacts", click to select a location such as Desktop at which you want to create the CSV format file, and then click Next.
    8. Click Finish.
  2. Delete all your contacts in the Contacts folder. To do so:
    1. Click the Contacts folder.
    2. Click Edit, and then click Select All to highlight all your contacts in the Contacts folder.
    3. Click Delete on the top toolbar or click Edit, and then click Delete.

      NOTE: If you have a large number of contacts (hundreds or even thousands), delete them in batches of hundreds at a time. If you delete all of them at one time, Outlook may stop responding (hang).
  3. Import the contacts back from the CSV file "Contacts.csv" on your desktop. To do so:
    1. On the File menu, click Import and Export.
    2. Click Import form another program or file, and then click Next.
    3. Click Comma Separated Values (Windows) and then click Next.
    4. Locate the CSV file "Contacts.csv" on your desktop.
    5. Click to select the Do not import duplicates check box, and then click Next.
    6. Click the Contacts folder under the mailbox tree of folders, and then click Next.
    7. Click Finish.
After you complete these steps, you can open your contacts, and you will not receive an error message.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:5/20/2003
Keywords:kbbug kbnofix kbsbt KB223845