ACC2000: Snapshot May Not Open Automatically After Running the User-Level Security Wizard (223234)



The information in this article applies to:

  • Microsoft Access 2000

This article was previously published under Q223234
Novice: Requires knowledge of the user interface on single-user computers.

This article applies only to a Microsoft Access database (.mdb).

SYMPTOMS

During the closing steps of the User-Level Security Wizard, you should see a print preview of the information contained in the workgroup file. When you close this report, you receive the following message:

Warning: You must have the information contained in this report to recreate your workgroup file if your original workgroup file is lost or corrupted. Do you want to the save the report as a Snapshot (.snp) file that you can view later?

If you click Yes the Snapshot file is saved to the same location as the secured database. The Snapshot file should then open, but only if you have previously installed the Snapshot Viewer.

CAUSE

The Snapshot Viewer is not installed by default; it is configured to install on demand.

RESOLUTION

Locate and open the Snapshot file. Note that the Windows Installer dialog box opens and installs the Snapshot Viewer. After the Snapshot Viewer is installed and the Windows Installer dialog box closes, you may have to try to open the Snapshot file again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Install Office 2000, selecting the Typical option.
  2. Start Microsoft Access.
  3. Create a new database.
  4. On the Tools menu, point to Security, and then click User-Level Security Wizard. Click Yes when prompted to open the database in shared mode, and run the Security Wizard.
  5. Click Finish.
  6. Close the report preview.
  7. Click Yes to save the report to a Snapshot file.

    Note that the Snapshot file is not opened as it would be if the Snapshot Viewer were installed.

Modification Type:MajorLast Reviewed:6/24/2004
Keywords:kbbug kbnofix KB223234